yolov3app.spec 1.8 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061
  1. #
  2. # spec file for package app
  3. #
  4. # Copyright (c) 2020 SUSE LINUX Products GmbH, Nuernberg, Germany.
  5. #
  6. # All modifications and additions to the file contributed by third parties
  7. # remain the property of their copyright owners, unless otherwise agreed
  8. # upon. The license for this file, and modifications and additions to the
  9. # file, is the same license as for the pristine package itself (unless the
  10. # license for the pristine package is not an Open Source License, in which
  11. # case the license is the MIT License). An "Open Source License" is a
  12. # license that conforms to the Open Source Definition (Version 1.9)
  13. # published by the Open Source Initiative.
  14. # Please submit bugfixes or comments via http://bugs.opensuse.org/
  15. # Author : Jianwei,Ding(00319713)
  16. name: Yolov3
  17. version: v1.0.0
  18. release: 1%{?dist}
  19. summary: description in one line
  20. license: -
  21. vendor: Yolov3
  22. %description
  23. Yolov3 Application
  24. %prep
  25. %build
  26. make vclean; make %{?_smp_mflags}
  27. %install
  28. rm -rf %{buildroot}
  29. mkdir -m 0755 -p %{buildroot}
  30. mkdir -m 0755 -p %{buildroot}/bin
  31. mkdir -m 0755 -p %{buildroot}/lib
  32. mkdir -m 0755 -p %{buildroot}/res
  33. mkdir -m 0755 -p %{buildroot}/res/html
  34. mkdir -m 0755 -p %{buildroot}/res/image
  35. install -m 755 %{_builddir}/config/startup.sh %{buildroot}/bin/main
  36. install -m 755 %{_builddir}/bin/yolov3app %{buildroot}/bin/
  37. install -m 755 %{_builddir}/model/*.wk %{buildroot}/lib
  38. install -m 755 %{_builddir}/config/portal.conf %{buildroot}/portal.conf
  39. install -m 755 %{_builddir}/config/hover.png %{buildroot}/res/image/hover.png
  40. install -m 755 %{_builddir}/config/index.html %{buildroot}/res/html/index.html
  41. install -m 666 %{_builddir}/config/sdc.conf %{buildroot}/sdc.conf
  42. %clean
  43. rm -rf %{buildroot}
  44. %files
  45. /*
  46. %defattr(-,root,root,-)
  47. %doc
  48. %changelog
  49. * Wed Jul 15 2020 Your Name <youremail@xxx.xxx> - Created
  50. - Update to 1.0