12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061 |
- #
- # spec file for package app
- #
- # Copyright (c) 2020 SUSE LINUX Products GmbH, Nuernberg, Germany.
- #
- # All modifications and additions to the file contributed by third parties
- # remain the property of their copyright owners, unless otherwise agreed
- # upon. The license for this file, and modifications and additions to the
- # file, is the same license as for the pristine package itself (unless the
- # license for the pristine package is not an Open Source License, in which
- # case the license is the MIT License). An "Open Source License" is a
- # license that conforms to the Open Source Definition (Version 1.9)
- # published by the Open Source Initiative.
- # Please submit bugfixes or comments via http://bugs.opensuse.org/
- # Author : Jianwei,Ding(00319713)
- name: Yolov3
- version: v1.0.0
- release: 1%{?dist}
- summary: description in one line
- license: -
- vendor: Yolov3
- %description
- Yolov3 Application
- %prep
- %build
- make vclean; make %{?_smp_mflags}
- %install
- rm -rf %{buildroot}
- mkdir -m 0755 -p %{buildroot}
- mkdir -m 0755 -p %{buildroot}/bin
- mkdir -m 0755 -p %{buildroot}/lib
- mkdir -m 0755 -p %{buildroot}/res
- mkdir -m 0755 -p %{buildroot}/res/html
- mkdir -m 0755 -p %{buildroot}/res/image
- install -m 755 %{_builddir}/config/startup.sh %{buildroot}/bin/main
- install -m 755 %{_builddir}/bin/yolov3app %{buildroot}/bin/
- install -m 755 %{_builddir}/model/*.wk %{buildroot}/lib
- install -m 755 %{_builddir}/config/portal.conf %{buildroot}/portal.conf
- install -m 755 %{_builddir}/config/hover.png %{buildroot}/res/image/hover.png
- install -m 755 %{_builddir}/config/index.html %{buildroot}/res/html/index.html
- install -m 666 %{_builddir}/config/sdc.conf %{buildroot}/sdc.conf
- %clean
- rm -rf %{buildroot}
- %files
- /*
- %defattr(-,root,root,-)
- %doc
- %changelog
- * Wed Jul 15 2020 Your Name <youremail@xxx.xxx> - Created
- - Update to 1.0
|